読者です 読者をやめる 読者になる 読者になる

かもメモ

自分の落ちた落とし穴に何度も落ちる人のメモ帳

Rubyをアップデートしようとしたらrbenvに最新版が表示されない時の対処法

Ruby

chaika.hatenablog.com

rbenvで管理しているRubyのバージョンを上げようとしたら、ruby-build、rbenvを最新版にしていても最新版のRubyのバージョンが表示されないという事態に遭遇しました。

ruby-build、rbenvを最新版にする

$ brew upgrade ruby-build rbenv

rbenvでインストールできるRubyのリストを表示

$ rbenv install --list

通常ならここでインストールできる最新版のRubyが表示されるのですが、今回は2.2.3以降が表示されませんでした...

解決方法

.rbenvの中にあるruby-buildを最新の状態にすればOK

$ cd ~/.rbenv/plugins/ruby-build
$ git pull

再度インストールできるRubyのリストを表示

$ rbenv install --list

最新版が表示されインストールできるようになりました!


[参考]

プログラミング言語 Ruby

プログラミング言語 Ruby